Page 1 of 1

LightUp [V.2.4a] + SketchUp8.0 crush problem

Posted: Fri Dec 02, 2011 2:46 am
by phonic
I've tried to install LightUp version up to [V.2.4a] from [v.2.3g] onto SketchUp 8.0.
However, after version up completed, my SketchUp crushed.

Before installing v.2.4a, I used to use v.2.3g+SketchUp 8.0 normally.
Therefore, I uninstalled SketchUp and LightUp, then re-installed
SketchUp 8.0+ LightUp v.2.3g again.

But, now SketchUp 8.0+LightUp v.2.3g doesn't work anymore.
It used to work!

Now, I'm using SketchUp only and works fine, but no LightUp.

I need to use LightUp v.2.4a and SketchUp8.0 together, how can I fix this problem ?

What is this problem caused??

Give me any suggestion, please.

OS:Windows 7.0 32bit

Re: LightUp [V.2.4a] + SketchUp8.0 crush problem

Posted: Fri Dec 02, 2011 12:02 pm
by AdamB
Hi,

Check SketchUp has not disabled your OpenGL graphics card. Sketchup Preferences->OpenGL->Use hardware acceleration

Do you get any messages from SketchUp?

If you install v2.4 LightUp, and run the menu Tools->LightUp->OpenGL Info, what does it print?

Adam

Re: LightUp [V.2.4a] + SketchUp8.0 crush problem

Posted: Mon Dec 05, 2011 1:39 am
by phonic
Actually, when I open LightUp welcome page, SketchUp crsahes, therefore unfortunately I can't check my OpenGL graphic card.
When SketchUp crashes, I see [SketchUp Application has stopped working] message.

Because of above crash, I changed lightmapui.rb script.
Line 89th
Original:dialog.show {dialog.execute_script("setStrings('#{LMap::LUJSSTRINGS}')")}
Modified:# dialog.show {dialog.execute_script("setStrings('#{LMap::LUJSSTRINGS}')")}

After modified script, LightUp 2.4a is working normally.
However, how can I run SketchUp8.0+LightUp 2.4a normally without modifying script?

Thank you for your information and advise, in advance.

Phonic 7

Re: LightUp [V.2.4a] + SketchUp8.0 crush problem

Posted: Thu Dec 08, 2011 8:08 pm
by AdamB
It sounds like there is a problem with your "lightup.strings" translation file.

If you go to {SKETCHUP FOLDER}/Resources/{LANGUAGE} and rename "lightup.strings" to something else and try and again. Does it resolve the issue?

Adam

Re: LightUp [V.2.4a] + SketchUp8.0 crush problem

Posted: Fri Dec 09, 2011 1:11 am
by phonic
Thanks for your advice.
I followed your guidance and renamed it, but it didn't work.

However, I found the problem!
It was cause of Adobe Flash Player which I modified the program before.

Now, everything work fine.

Thank you for your time and advice, again.

Phonic