Accurate reflections

Features you'd like to see in future versions, gripes, ideas..
Post Reply
sycohead
Posts: 5
Joined: Fri Feb 24, 2012 8:21 pm

Accurate reflections

Post by sycohead » Fri Feb 24, 2012 8:30 pm

I us an HP Laptop with Intel (R) HD Graphics Family (ATI Technologies.) and the Radeon (TM) HD6770M display adapters.
For some reason I cannot get an accurate reflection from any surface. I have tried using uvlmaps, Irr-cache and various .png images but I still cannot get an accurate reflection (like a chairs reflection on a shinny floor)

I have updated all of my drivers and installed the latest Maintenece build.
Please help.

Thanks :)

User avatar
AdamB
Site Admin
Posts: 2294
Joined: Wed Apr 16, 2008 10:11 am
Location: Brighton, UK
Contact:

Re: Accurate reflections

Post by AdamB » Fri Feb 24, 2012 9:36 pm

Hi

Your laptop has 2 graphics chips. You must choose in your Control Panel which graphics chip it will use before starting SketchUp.

The "Intel (R) HD Graphics" chip are for word processing and low power use.
The Radeon is for more intensive 3D. So I'd suggest you choose the Radeon chip, start SketchUp and you'll need to re-enable "Use hardware acceleration" in SketchUp when you switch chips.

Now in LightUp, the menu Tools->LightUp->OpenGL Info, should show it using the Radeon chip and you then get reflections etc.

Adam
Developer of LightUp http://www.light-up.co.uk

sycohead
Posts: 5
Joined: Fri Feb 24, 2012 8:21 pm

Re: Accurate reflections

Post by sycohead » Fri Feb 24, 2012 9:45 pm

Could you give me a step-by-step walkthrough on how I switch my chip to the Radeon?
Ive tried to figure it out myself but I am not finding an option like that.

Thanks for all your help. It is a great product :)

sycohead
Posts: 5
Joined: Fri Feb 24, 2012 8:21 pm

Re: Accurate reflections

Post by sycohead » Sat Feb 25, 2012 12:22 am

Nevermind,

After searching around I found what should have been the obvious solution.

For anyone else have a similar problem, follow the steps below:

1. Reboot
2. Press F10 to enter Boot setup mode.
3. Change Switchable Graphics from "Dynamic" to "Fixed"
4. Save and exit.

Now Lightup's openGL will recognise the Radeon HD 6770M GPU.
BONUS!

Post Reply