Mapped Material Renders Black

Anything you want to share!
Post Reply
measuredmove
Posts: 16
Joined: Sun Dec 07, 2014 4:28 pm

Mapped Material Renders Black

Post by measuredmove » Sun May 15, 2016 2:44 pm

Hopefully my last problem....
I lose the mapping on some rendered items with black sections.
Thanks for you help Adam
Attachments
Render4.png
Render4.png (2.1 MiB) Viewed 3599 times

User avatar
AdamB
Site Admin
Posts: 2294
Joined: Wed Apr 16, 2008 10:11 am
Location: Brighton, UK
Contact:

Re: Mapped Material Renders Black

Post by AdamB » Wed May 18, 2016 7:51 pm

Looks like the surface normals are flipped have way across the surface..

If you render using "Show Normals" do all the colors (representing directions) change smoothly?

Adam
Developer of LightUp http://www.light-up.co.uk

measuredmove
Posts: 16
Joined: Sun Dec 07, 2014 4:28 pm

Re: Mapped Material Renders Black

Post by measuredmove » Wed May 18, 2016 10:49 pm

Hi Adam
Not sure how to Show Normals but I'll attach the object.

The way it was created may be the problem:
2D Photo brought into PhotoAnimate, given 3d volume and mirrored, saved as a .3ds object
Opened in Simlab Composer and saved as a ,skp file.
I've made hundreds of these objects so any solution would be hugely appreciated!
Attachments
Pillow-Givenchy.skp
(3.27 MiB) Downloaded 215 times

measuredmove
Posts: 16
Joined: Sun Dec 07, 2014 4:28 pm

Re: Mapped Material Renders Black

Post by measuredmove » Tue May 31, 2016 12:29 pm

Just wondering if there was any update on this issue also
Thanks

User avatar
AdamB
Site Admin
Posts: 2294
Joined: Wed Apr 16, 2008 10:11 am
Location: Brighton, UK
Contact:

Re: Mapped Material Renders Black

Post by AdamB » Thu Jun 02, 2016 6:47 pm

[You can always do a 'render' of the surface normals of your model by opening Preferences->Lighting and in the dropdown, choose the <<Check Normals>> mode.]

The problem was being caused because the pillow material has a very small amount of transparency in it - so little you may not have noticed it. However LightUp was trying to resolve the transparency and not doing a good job.

Select the QueryTool, and Apple/Alt click on the material and check "Force Masked". This mode tells LightUp to treat the transparency as either all opaque or all transparent.

See this video for more info: LightUp Essentials: Materials

Notice the black spots? Those are actually tiny holes in the texture showing the unlit interior.
pillow.jpg
pillow.jpg (219.7 KiB) Viewed 3423 times
Developer of LightUp http://www.light-up.co.uk

measuredmove
Posts: 16
Joined: Sun Dec 07, 2014 4:28 pm

Re: Mapped Material Renders Black

Post by measuredmove » Sat Jun 04, 2016 5:40 pm

Thanks very much for your help with this.
Cheers

Post Reply