Page 1 of 1

Material appears black?!?

Posted: Tue Nov 19, 2013 5:01 pm
by Crafty1980
Urgh, help! this is doing my head in!

Ok, so I've drawn up a complete model of a house... inside and out. I had it all textured up and tried to apply lights to it but when I hit the tourtool everything rendered except the material for the outside of the house. It just rendered it as a completely black surface when the material was white...

I've tried making a new material etc and still nothing...

I've now gone to the extreme of completely stripping the model of all of its materials, just to see what happens.
I've removed all the lights too... and deleted all the lightup cache...

I turned on the sun to see what happens, and I still get this:

Why is the surface of the house appearing black?!?! None of the other surfaces seem to be affected... Even if I add a new material to those surfaces, it still renders as black...

Re: Material appears black?!?

Posted: Tue Nov 19, 2013 10:48 pm
by AdamB
It looks like the material on the outside has a overloaded diffuse color of black.

If you checkbox Lighting Only in Preferences, is the lighting correct?

Double click on the outside material and Reset it. Or make it not black.


Re: Material appears black?!?

Posted: Tue Nov 19, 2013 11:46 pm
by Crafty1980
But that's just my point... There are NO materials in this model.

I've stripped it completely of all lights and materials...

The only thing selected is to use the sun...

Surely then, if there are no materials set at all, everything should still appear white when clicking on the tour tool?
(Like all the other white surfaces in the model... The roof, windows, etc)

Everything has been set the same yet still that one object appears black...

It's as if the "renderer" is ignoring that component in its calculation. Is that even possible?
I'll try and explode it and recreate a new component again tomorrow...

Most odd...

Re: Material appears black?!?

Posted: Wed Nov 20, 2013 10:08 am
by Crafty1980
Here's another prime example:

2 rooflights.. One is an exact carbon copy of the other... Hit render and one produces shadows etc... the other one is completely black!

The chimney also turns black...

Any ideas as to why this is?

Re: Material appears black?!?

Posted: Wed Nov 20, 2013 10:27 am
by max
Could you add the SketchUp file? More easy to find out whats causing the problem.

Re: Material appears black?!?

Posted: Wed Nov 20, 2013 12:34 pm
by Crafty1980
Sketchup file attached:


Re: Material appears black?!?

Posted: Wed Nov 20, 2013 2:18 pm
by max
Crafty, I had a look at your 3d model. I'm sorry but I can't reproduce your problem. All renders well.

Maybe you can post your gfx-card specs, OS + version, LightUp version?

You could try the following:
1) under tools\lightUp\ choose 'remove all LightUp info' and 'clear LightUp cache' -> this will remove any (strange) settings you might have made at some point. I guess it won't do anything but you can try.
2) Try what happens if you change the calculation settings (see image). It looks like you don't need double sided (for exteriors). Maybe one of these settings is causing the problem but again I guess it won't help.

The calculation sequence is a bit different compared to my models. It calculates to 100% and stays there for a minute and only after the minute it displays the result. I can't remember I have seen that before and don't know what this means.

good luck!


Re: Material appears black?!?

Posted: Wed Nov 20, 2013 2:46 pm
by Crafty1980
Well would you believe it... I've just done what you've suggested and, even though I'd deleted the cache and removed all lightup info before, it now seems to have cleared itself!

Most peculiar!

Thanks for the help though... sometimes it's the simplest things I guess... :-/

Re: Material appears black?!?

Posted: Wed Jul 24, 2019 9:23 pm
by lightupines

Same thing happens to me, but with the whole model. I've everything you suggested, but it doesn't seem to work. Down here you have links to pictures of the problem. Please help me! ... 1.png?dl=0 ... 8.png?dl=0